Landasan Teori
Static Routing
Static routing adalah salah satu metode (pembuatan tabel) routing yang dilakukan secara manual oleh administrator jaringan.
Keuntungan Static routing : - Lebih aman daripada dynamic routing terhadap metode spoofing
Kelemahan : -rentan terhadap kesalahan penulisan -lebih merepotkan dibandingkan dynamic routing.

Dynamic Routing
Dynamic routing adalah teknik routing dengan menggunakan beberapa aplikasi networking yang bertujuan menangani routing secara otomatis. Tabel routing (ARP table) akan dimaintain oleh sebuah protokol routing, biasanya daemon
Keuntungan dari dynamic routing:  Lebih mudah untuk mengatur network yang besar.  Akan memilih jalur lain yang ada bila suatu jalur rusak.
Kekurangan dari dynamic routing: - update ARP table dibagikan ke semua komputer, berarti mengkonsumsi bandwith  butuh RAM untuk menentukan jalur terbaik bila terjadi down  jalur ditentukan oleh sistem, bukan admin
Contoh dari dynamic routing adalah RIP dan OSPF.


Routing Information Protocol (RIP) adalah sebuah protokol routing dinamis yang digunakan dalam jaringan LAN (Local Area Network) dan WAN (Wide Area Network). Karena itu protokol ini diklasifikasikan sebagai Interior Gateway Protocol (IGP). Protokol ini menggunakan algoritma Distance-Vector Routing. Pertama kali didefinisikan dalam RFC 1058 (1988). Protokol ini telah dikembangkan beberapa kali, sehingga terciptalah RIP Versi 2 (RFC 2453). Kedua versi ini masih digunakan sampai sekarang, meskipun begitu secara teknis mereka telah dianggap usang oleh teknik-teknik yang lebih maju, seperti Open Shortest Path First (OSPF) dan protokol OSI IS-IS. RIP juga telah diadaptasi untuk digunakan dalam jaringan IPv6, yang dikenal sebagai standar RIPng (RIP Next Generation / RIP generasi berikutnya), yang diterbitkan dalam RFC 2080 (1997).
Open Shortest Path First (OSPF) adalah sebuah routing protokol standar terbuka yang telah di implementasikan oleh sejumlah besar vendor jaringan.
OSPF bekerja dengan sebuah algoritma yang disebut Dijkstra. Pertama, sebuah pohon jalur terpendek (shortest path tree) akan dibangun, dan kemudian routing table akan diisi dengan jalur terbaik yang dihasilkan dari pohon tersebut. OSPF melakukan converge dengan cepat, meskipun tidak secepat EIGRP, dan OSPF mendukung multiple route dengan biaya (cost) yang sama, ketujuan yang sama.

Simulasi
Persiapan:
Sistem yang digunakan oleh penulis :
1. Sistem Operasi : Linux Ubuntu 11.04
2. Cisco Packet Tracer for Linux untuk Simulator
3. Libre Office untuk dokumentasi    

Langkah-langkah:
1. Static Routing
Buat skema berikut dengan Cisco Packet Tracer:

1. Menghitung jumlah host yang digunakan
N1 + N2 + N3 + N4 + N5 + N6 + N7 + N8 + N9 = 16+32+8+4+32+4+4+4+4=108 host
2. Menentukan net prefiks dan alokasi IP
N1 = 14 | 4 bit -> 192.168.1.0 /28
N2 = 28 | 5 bit -> 192.168.1.16 /27
N3 = 7 | 3 bit -> 192.168.1.48 /29
N4 = 2 | 2 bit -> 192.168.1.56 /30
N5 = 28 | 5 bit -> 192.168.1.60 /27
N6 = 2 | 2 bit -> 192.168.1.92 /30
N7 = 2 | 2 bit -> 192.168.1.96 /30
N8 = 2 | 2 bit -> 192.168.1.100 /30
N9 = 2 | 2 bit -> 192.168.1.104 /30
3. Menentukan Nilai Interface

Router
e0
e1
e2
R1
192.168.1.1
192.168.1.101
192.168.1.93
R2
192.168.1.94
192.168.1.97
192.168.1.17
R3
192.168.1.98
192.168.1.49
-
R4
192.168.1.102
192.168.1.57
192.168.1.105
R5
192.168.1.106
192.168.1.61
-
4. Menentukan gateway / next hop

Network
R1
R2
R3
R4
R5
N1
direct
192.168.1.93
192.168.1.97
192.168.1.101
192.168.1.105
N2
192.168.1.94
direct
192.168.1.97
192.168.1.101
192.168.1.105
N3
192.168.1.94
192.168.1.98
direct
192.168.1.101
192.168.1.105
N4
192.168.1.102
192.168.1.93
192.168.1.97
192.168.1.direct
192.168.1.105
N5
192.168.1.102
192.168.1.93
192.168.1.97
192.168.1.106
direct
N6
direct
direct
192.168.1.97
192.168.1.101
192.168.1.105
N7
192.168.1.94
direct
direct
192.168.1.101
192.168.1.105
N8
direct
192.168.1.93
192.168.1.97
direct
192.168.1.105
N9
192.168.1.102
192.168.1.93
192.168.1.97
direct
direct


2. Dynamic Routing (RIP versi 1)
Buat skema berikut :

Masukan perintah berikut pada CLI Router nya;
Router A:
Router>en
Router# conf t
Router(config)#int f 0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shut

Router(config)#int s 1/0
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#clock rate 800000
Router(config-if)#no shut

Router B:
Router>en
Router#conf t
Router(config)#int s 0/0
Router(config-if)#ip address 192.168.2.2 255.255.255.0
Router(config-if)#clock rate 800000
Router(config-if)#no shut
Router(config-if)#int s 1/0
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#clock rate 800000
Router(config-if)#no shut

Router C

Router>en
Router#conf t
Router(config)#int s 0/0
Router(config-if)#ip address 192.168.3.2 255.255.255.0
Router(config-if)#clock rate 800000
Router(config-if)#no shut
Router(config-if)#int s 1/0
Router(config-if)#ip address 192.168.4.1 255.255.255.0
Router(config-if)#clock rate 800000
Router(config-if)#no shut
Router(config-if)#int s 2/0
Router(config-if)#ip address 192.168.5.1 255.255.255.0
Router(config-if)#clock rate 800000
Router(config-if)#no shut

Router D
Router>en
Router#conf t
Router(config)#int f 0/0
Router(config-if)#ip address 192.168.10.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#int s 1/0
Router(config-if)#ip address 192.168.5.2 255.255.255.0
Router(config-if)#clock rate 800000
Router(config-if)#no shut
Router(config-if)#int s 2/0
Router(config-if)#ip address 192.168.6.1 255.255.255.0
Router(config-if)#clock rate 800000
Router(config-if)#no shut

Router E
Router>en
Router# conf t
Router(config)#int f 0/0
Router(config-if)#ip address 192.168.8.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#int s 1/0
Router(config-if)#ip address 192.168.4.2 255.255.255.0
Router(config-if)#clock rate 800000
Router(config-if)#no shut
Router(config-if)#int s 2/0
Router(config-if)#ip address 192.168.7.1 255.255.255.0
Router(config-if)#clock rate 800000
Router(config-if)#no shut

Router F

Router>en
Router#conf t
Router(config)#int f 0/0
Router(config-if)#ip address 192.168.9.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#int s 1/0
Router(config-if)#ip address 192.168.7.2 255.255.255.0
Router(config-if)#clock rate 800000
Router(config-if)#no shut
Router(config-if)#int s 2/0
Router(config-if)#ip address 192.168.6.2 255.255.255.0
Router(config-if)#clock rate 800000
Router(config-if)#no shut
Konfigurasi RIP

Router A
Router(config)#router rip
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.2.0

Router B
Router(config-if)#router rip
Router(config-router)#network 192.168.2.0
Router(config-router)#network 192.168.3.0

Router C
Router(config-if)#router rip
Router(config-router)#network 192.168.3.0
Router(config-router)#network 192.168.4.0
Router(config-router)#network 192.168.5.0

Router D
Router(config-if)#router rip
Router(config-router)#network 192.168.5.0
Router(config-router)#network 192.168.6.0
Router(config-router)#network 192.168.10.0

Router E
Router(config-if)#router rip
Router(config-router)#network 192.168.4.0
Router(config-router)#network 192.168.7.0
Router(config-router)#network 192.168.8.0

Router F
Router(config-if)#router rip
Router(config-router)#network 192.168.6.0
Router(config-router)#network 192.168.7.0
Router(config-router)#network 192.168.9.0

3. Dynamic Routing (RIP versi 2)
Buat skema :


IP Private Net Mask
N1 = 60 + 2 = 62  /26 188.22.55.0/26 255.255.255.192
N2 = 50 + 2 = 52  /26 188.22.55.64/26 255.255.255.192
N3 = 14 + 2 = 16  /28 188.22.55.128/28 255.255.255.240
N4 = 13 + 2 = 15  /28 188.22.55.144/28 255.255.255.240
N5 = 10 + 2 = 12  /28 188.22.55.160/28 255.255.255.240
N6 =   6 + 2 =   8  /29 188.22.55.176/29 255.255.255.248
N7 =     6 + 2 =  8  /29 188.22.55.184/29 255.255.255.248
IP Public Net Mask
N8 = 2 + 2 = 4  /30 222.44.33.0/30 255.255.255.252
N9 = 2 + 2 = 4  /30 222.44.33.4/30 255.255.255.252
N10 = 2 + 2 = 4  /30 222.44.33.8/30 255.255.255.252
Penentuan IP di Router
R1   R2            R3
e0 = 188.22.55.129/28 e0 = 188.22.55.65/26    e0     = 188.22.55.1/26
e1 = 188.22.55.161/28 e1 = 188.22.55.185/29                e1     = 188.22.55.145/28
e2 = 188.22.55.177/29 e2 = 222.44.33.2/30                   e2    = 222.44.33.6/30
e3 = 222.44.33.1/30 e3 = 222.44.33.5/30                   e3    = 222.44.33.10/30
e4  = 222.44.33.9/30       Perhitungan :
IP Public 222.44.33.0/24
IP Private 188.22.55.0/24coding CLI Penginputan IP pada masing2 router:
Router 1
Router>en
Router#conf t
Router(config)#hostname A
A(config)#int f0/0
A(config-if)#ip address 188.22.55.129 255.255.255.240
A(config-if)#no shut
A(config-if)#int f1/0
A(config-if)#ip address 188.22.55.161 255.255.255.240
A(config-if)#no shut
A(config-if)#int f2/0
A(config-if)#ip address 188.22.55.177 255.255.255.248
A(config-if)#no shut
A(config-if)#int s3/0
A(config-if)#ip address 222.44.33.1 255.255.255.252
A(config-if)#clock rate 800000
A(config-if)#no shut
A(config-if)#int s4/0
A(config-if)#ip address 222.44.33.9 255.255.255.252
A(config-if)#clock rate 800000
A(config-if)#no shut
Router 2
Router>en
Router#conf tRouter(config)#hostname B
B(config)#int f0/0
B(config-if)#ip address 188.22.55.65 255.255.255.192
B(config-if)#no shut
B(config-if)#int f1/0
B(config-if)#ip address 188.22.55.185 255.255.255.248
B(config-if)#no shut
B(config-if)#int s2/0
B(config-if)#ip address 222.44.33.2 255.255.255.252
B(config-if)#clock rate 800000
B(config-if)#no shut
B(config-if)#int s3/0
B(config-if)#ip address 222.44.33.5 255.255.255.252
B(config-if)#clock rate
B(config-if)#clock rate 800000
B(config-if)#no shut
Router 3
Router>en
Router#conf t
Router(config)#hostname C
C(config)#int f0/0
C(config-if)#ip address 188.22.55.1 255.255.255.192
C(config-if)#no shut
C(config-if)#int f1/0
C(config-if)#ip address 188.22.55.145 255.255.255.240
C(config-if)#no shut
C(config-if)#int s2/0C(config-if)#ip address 222.44.33.6 255.255.255.252
C(config-if)#clock rate 800000
C(config-if)#no shut
C(config-if)#int s3/0
C(config-if)#ip address 222.44.33.10 255.255.255.252
C(config-if)#clock rate 800000
C(config-if)#no shut

CLI Rip versi 2
Router 1
A(config)#router rip
A(config-router)#version 2
A(config-router)#network 188.22.55.128
A(config-router)#network 188.22.55.160
A(config-router)#network 188.22.55.176
A(config-router)#network 222.44.33.0
A(config-router)#network 222.44.33.8
Router 2
B(config)#router rip
B(config-router)#version 2
B(config-router)#network 188.22.55.64
B(config-router)#network 188.22.55.184
B(config-router)#network 222.44.33.0
B(config-router)#network 222.44.33.4
Router 3
C(config)#router rip
C(config-router)#version 2
C(config-router)#network 188.22.55.0
C(config-router)#network 188.22.55.144
C(config-router)#network 222.44.33.4
C(config-router)#network 222.44.33.8

4. OSPF
Buat skema berikut :


IP: 172.23.0.0/16

Network
Host
Alokasi
Net Prefix
N3
100 + 2 = 102
172.23.0.0
/25
N2
50 + 2 = 52
172.23.0.128
/26
N4
35 + 2 = 37
172.23.0.192
/26
N8
35 + 2 = 37
172.23.1.0
/26
N6
25 + 2 = 27
172.23.1.64
/27
N1
18 + 2 = 20
172.23.1.96
/27
N7
12 + 2 = 14
172.23.1.128
/28
N5
6 + 2 = 8
172.23.1.144
/29
N9
2 + 2 = 4
172.23.1.152
/30
N10
2 + 2 = 4
172.23.1.156
/30
N11
2 + 2 = 4
172.23.1.160
/30
N12
2 + 2 = 4
172.23.1.164
/30
N13
2 + 2 = 4
172.23.1.168
/30
N14
2 + 2 = 4
172.23.1.172
/30
N15
2 + 2 = 4
172.23.1.176
/30

Selanjutnya lakukan seperti cara paling pertama yaitu menentukan interface dan subnet mask. Nilai Alokasi sebagai acuan IP pada tiap Network (N) dan Router.

DOWNLOAD VERSI PDF dan File Packet Tracer (pkt)

2 comments:

  1. follow pluys pemberitahuan bahwa info mengenai kontes seo sudah di update

    BalasHapus
  2. sip keren mas..
    saya ijin download ya mas.. :D

    BalasHapus

Silahkan Komentar, Kritik atau Saran.

 
Top